JCoins Voucher Errors

  • In my logs I see:

    Code
    Use of undefined constant MODULE_JCOINS_VOUCHER - assumed 'MODULE_JCOINS_VOUCHER' (this will throw an Error in a future version of PHP)

    I think it is tied to the fact that I cannot enable jCoin vouchers here:
    [Blocked Image: https://cdn.discordapp.com/attachments/807424509174349844/810623542290022400/Screen_Shot_2021-02-14_at_1.28.19_PM.png]


    And this it is not actually activated in the system.


    I may be wrong of course, but can you help? This is a new install of jCoins vouchers on WotLab Suite 5.3.x Thanks in advance!

  • According to my experience, such an error is the result of a failed installation, possibly in conjunction with a cache problem. Both would be a WSC problem not related to Vouchers. The missing constant definitely is part of the Voucher package and should have been installed.


    I can only recommend to uninstall it and to try again.

  • RE-installed, still errors :(


    Message: Unable to find template 'userPanelJCoinsDropdownVoucher'

    PHP version: 7.2.34-8+ubuntu18.04.1+deb.sury.org+1

    WoltLab Suite version: 5.3.4

    Request URI: GET /

    Referrer: User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.150 Safari/537.36 Edg/88.0.705.63

    Peak Memory Usage: 3581160/1073741824

    ======

    Error Class: wcf\system\exception\SystemException

    Error Message: Unable to find template 'userPanelJCoinsDropdownVoucher'

    Error Code: 0

    File: /var/www/html/suite/lib/system/template/TemplateEngine.class.php (364)

    Extra Information: -

    Stack Trace: [{"file":"/var/www/html/suite/lib/system/template/TemplateEngine.class.php","line":447,"function":"getSourceFilename","class":"wcf\system\template\TemplateEngine","type":"->","args":["__userPanelJCoinsDropdownVoucher","wcf"]},{"file":"/var/www/html/suite/lib/system/template/TemplateEngine.class.php","line":322,"function":"isCompiled","class":"wcf\system\template\TemplateEngine","type":"->","args":["offline","/var/www/html/suite/templates/offline.tpl","/var/www/html/suite/templates/compiled/3_wcf_1_offline.php","wcf",{"include":"[redacted]"}]},{"file":"/var/www/html/suite/lib/system/request/RequestHandler.class.php","line":99,"function":"display","class":"wcf\system\template\TemplateEngine","type":"->","args":["offline"]},{"file":"/var/www/html/index.php","line":9,"function":"handle","class":"wcf\system\request\RequestHandler","type":"->","args":["wbb"]}]

  • We figured out what the issue was and it was actually unrelated to installation. I characterize my error as PEBCAC: Problem exists between computer and chair. I'm saving some pride and shall not divulge the stupidity. THANK YOU.

  • UdoZ

    Added the Label Not a bug